Skip to main content

Table Of Contents

  • Solaris OS
    • Solaris File System Structure
    • Solaris Commands

SOLARIS OS

SOLARIS FILE SYSTEM STRUCTURE

PATHDESCRIPTION
/etc/vfstabFile system mount table
/var/adm/authlogLogin attempt log
/etc/default/*Default settings
/etc/systemKernel modules & config
/var/adm/messagesLogs system messages and errors
/etc/auto_*Automounter config files
/etc/inet/ipnodesIPv4/IPv6 host file

SOLARIS COMMANDS

List interfaces and routes

ifconfig -a
netstat -in

Start DHCP client

ifconfig <INTERFACE_NAME> dhcp start

Set IP

ifconfig <INTERFACE_NAME> <IP_ADDRESS> + <NETMASK>

Set gateway

route add default <IP_ADDERSS>

List users without passwords

logins -p

List all services with status

svcs -a

List processes

prstat -a

Start SSH service

svcadm enable ssh

Enable telnet (-d = disable)

inetadm -e telnet

List physical memory and hard disk size

prtconf | grep Memory
iostat -n

Restart system

shutdown -i6 g0 -y

List clients connected to NFS

dfmounts

Launch management GUI

smc

Capture specific number of packets and write to file

snoop -d <INTERFACE_NAME> -c <NUMBER_OF_PACKETS> -o <OUTPUT_PATH>